System.EnterpriseServices.Wrapper.dll' is not an assembly

edited November 2016
I have tried to get around this but it doesn't want to give in.

I solved the enterprise services wrapper issue by finding the dependentassembly tag in the config file and deleting it. But it wasn't a problem for visual studio.... right?

Your compiler does not read the bin folder and config file of our asp.net mvc app the way visual studio does. Does that question infer that I want LinqPad to work 'like visual studio'? I don't think so, in case that came up in your mind.

I keep getting errors like: CS0234 The type or namespace name 'WebPages' does not exist in the namespace 'Microsoft.Web' (Press F4 to check imported namespaces)

some of these I can find things to reference for others I cannot. Some show up in the 'additional imported namespaces' but that appears to be a just a complicated text box. Adding things to a text box that don't have an effect on the operation of the app seems... well just ...

If I remove the additional namespaces those errors go away, but then the next (obviously essential) namespace from a required DLL appears as the target of CS0234. Add some Infinitum and so on. It starts an avalanche of deletes that eventually have to be added in order to start errors that require deletes and you know.

I keep manually adding dll's in the bin to the list of libraries in Linqpad, but some of them aren't there. Maybe they're embedded in another dll?

Unless you are willing to provide a comprehensive manual for this library referencing scheme you have devised, only a telepath or your coding buddies can have a reliable experience.

Or if it's only for the 'special ones' who can trace dependencies in their sleep, please just say so.

And I know I'm not asking a specific question. That's the whole point about documentation, isn't it? it's for those moments when you don't know what is wrong and you have to know enough to find some kind of way to make it work.

Maybe you think 'simple is better', some people do. I think 'Intelligible and Working' are better.

I keep pouring hours over this precipice, but I can't fill up the void.

Please give me some guidance that will make this thing work for an hour, a couple days, a week or two?

Thanks,

Kimball Johnson
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!