The user instance login flag is not allowed when connecting to a user instance of SQL Server.

LINQPad v5.20.02

Steps to reproduce:
- (Make sure SQL Server LocalDB is installed)
- Open sample C# 6.0 in a Nutshell > Before You Start > Readme.First()
- Open connection properties dialog
- Change server name into (localdb)\v11.0
- Click 'Test'
- An error dialog appears:

---------------------------
LINQPad
---------------------------
The user instance login flag is not allowed when connecting to a user instance of SQL Server. The connection will be closed.
---------------------------
OK
---------------------------

Cause:
It seems that the 'User instance' checkbox is not visible for (localdb) servers, but is still checked.
You have to temporarily change the server name to deselect the checkbox.

Fix:
Alter LINQPad.UI.CxForm.EnableControls() to disable chkUserInstance.Checked when server name contains (localdb)
(apply same logic as deselecting SQL Server, SQL Authentication or Attach database file)
If this is odd in a UX kind of way, check for user instance applicability in connection string builder.

Comments

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!