FSharp.Data and IntelliSense in LINQPad - constant exception throwing

Hi,

I'm using LINQPad Premium v5.22.02 . (I've tried regular and AnyCPU with the same result.)

Steps to reproduce:

Open LINQPad. Change Language dropdown to "F# Program". Use NuGet Package Manager to add latest version of FSharp.Data (2.3.2) plus the namespace.

Go back to the query window and type

Http.Request

At some point during the typing of the word "Request", LINQPad tells me an error has occurred of type System.Xml.XmlException. Under "View More Details" it says, "An error occurred while parsing EntityName. Line 1, Position 218."

Even if I type it in another window and paste it in, when I mouse over it I get the error again.

This is making it pretty much impossible for me to play around with FSharp.Data in LINQPad - and given that the reason I bought a licence today was to do exactly that, as you can imagine it's quite frustrating :/

Any ideas?

Comments

  • Thanks for reporting. I've just uploaded a fix in the new beta:

    https://www.linqpad.net/Download.aspx#beta
  • Hi Joe, thanks for the speedy response.

    I've downloaded the beta (v5.22.03) and now it appears that *no* IntelliSense is working in my F# program window at all... In a C# window it's working as expected.

    I also wanted to add, as a follow-up to my last message, that FSharp.Data wasn't the only reason I bought a LINQPad licence. I use LINQPad every day, for work and outside of work - for database queries, for playing with code fragments, for solving puzzles from codewars.com , for teaching myself F# ... It's absolutely invaluable, and thank you for making it, and you deserve my money :)

    Jason
  • OK so I'm not sure why, exactly, but today it looks like F# IntelliSense *is* working for me. Possibly when I retested with the beta I didn't set up my sample correctly?

    Anyway, it looks as though things are now as they should be. Thanks for getting back to me Joe, much appreciated.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!