F#. Packages referring old version of FSharp.Core

edited June 19
Hi I am using packages that are referring old version of FSharp.Core (namely FSharp.Data, SQLProvider). When trying to run the query it is failing with MissingMethodException. The solution that sometimes work is to refer old FSharp.Core as a reference but sometimes it causes issues with the same exception but now pointing to FSharpAsync. If you write application same application in the Visual Studio to workaround the exception instead of referring old FSharp.Core you need to add following section in the App.Config:

<runtime>
<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
<dependentAssembly>
<assemblyIdentity name="FSharp.Core" publicKeyToken="b03f5f7f11d50a3a" culture="neutral" />
<bindingRedirect oldVersion="0.0.0.0-4.4.0.0" newVersion="4.4.0.0" />
</dependentAssembly>
</assemblyBinding>
</runtime>

Is there a way to do same in the LinqPad?

Comments

  • Have you tried going to Query | App.config (Ctrl+Shift+O) and pasting in the config?
  • Wow. Have been using LinqPad for few years and didn't even noticed that there is app.config override. That worked. Thanks!
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!