NuGet with a dot in the prerelease identifier breaks LINQPad

I am experiencing exceptions in LINQPad when the Add Nuget window encounters a prerelease package with a dot in the identifier.

Works: 1.0.0-alpha
Works: 1.0.0-alpha-1
Breaks:1.0.0-alpha.1

The error from an actual internal package:
System.ArgumentException

'3.2.3-release.1' is not a valid version string. Parameter name: version
The prereleases show up correctly in nuget.exe searches and in Visual Studio's NuGet package manager.

Per semver.org v2 specs, dots are supposed to be allowed: semver.org/#spec-item-9

Comments

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!