Execution tracking stops showing a yellow arrow after a breakpoint

Steps to reproduce
1. Start script execution
2. During execution, put a breakpoint ahead of the currently executed line (e.g., in a loop)
3. When execution pauses at breakpoint, remove the breakpoint and press F5 to resume

Expected
Yellow arrow still tracks execution

Actual
Yellow arrow disappears. Disabling & re-enabling auto track feature doesn't help. Ctrl+Shift+J still jumps to the currently executed line.

Comments

  • I can't reproduce this. Can you post a script?
  • Actually, I noticed now that it says in the bottom "execution tracking timed out". Is it possible to extend tracking period? Didn't find anything in the preferences menu.
  • Execution tracking incurs an overhead, and LINQPad constantly monitors the overhead to ensure that it doesn't exceed around 5%. The timeout message occurs when this overhead is exceeded, and this usually happens only in special scenarios, when it takes unusually long to obtain a stack trace.

    It's possible, though, that a debugger breakpoint could create a race that could result in a false positive. If you can reproduce it, post the script and I'll have a look.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!