Missing Table in x86 build


I'm a long-time user of LinqPad, but ran into my first problem with it today.
I connect to a SQL database (SuperOffice CRM) to export some data. Unfortunately, one of the tables I need (called crm7.PROJECT) is simply missing. I deactivated pluralization because some time ago I searched for the table PERSON which was renamed to PEOPLE, resulting in me not finding it. However, this did not help in this case.

It DOES show up if I use the AnyCPU build of LinqPad, but not in the x86 build. I'm using version 5.26.01 premium edition.

For now I use the AnyCPU build, but maybe there is a bug here?

I'd like to apologize for my bad English ^^°

Thanks a lot,



  • Have you tried right-clicking the connection and choosing 'Refresh'?
  • Hi Joe,

    Yes, have tried that. I also removed the connection and readded it, made no difference.
  • Are you able to test this on another machine?
  • Just did that, tested on a Server 2016 machine and on another Win10 x64 client, both did not show the PROJECT table.

    Then I ran LinqPad on the Server 2008 R2 which is the database server (SQL Server 12.0.5207 btw, i.e. SQL Server 2014) , where the table did show up.

    I've copied the database to a SQL 2017 server on Win10 and ran LinqPad on the same machine - again the table did not show up.
  • I'm not sure if it's potentially related to this or not, but my SQL Server 2008 R2 database has some tables that don't show up in the LINQPad table tree for that database regardless of what version I run.

    I've tested in 4.58.00 Premium as well as the X86 and AnyCPU builds of 5.26.01 Premium and both of the 5.28.05 beta builds as well across a Windows 7 machine and two Windows 10 laptops. Additionally versions of the same database are on three different distinct servers with the same result across all of them.

    One such table is named Price, for example; refreshing has no effect on this, nor does turning Pluralization off.

    As far as I can tell there's nothing special about that table (column types, indexes, permissions etc) that's any different from other tables that also exist and are visible, so I'm not sure why it would be omitted from the list. In particular simple queries from such a table work just fine using the connection.
  • If you create a database with *just* the crm7.PROJECT table in it, do you get the same problem?
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!