Update IQ Driver to be able to connect to Oracle 12.2.0.1.0

When I try to connect to an Oracle 12.2.0.1.0 instance, I get the following error: ORA-28040: No matching authentication protocol.

I presume it's because the Devart library included in the IQ driver is outdated. See https://forums.devart.com/viewtopic.php?t=36439

Can you update the driver please?

Ps: you can reproduce this by trying to connect to a local Oracle database hosted in a Docker container (for free), see https://store.docker.com/images/oracle-database-enterprise-edition

Further information:
Linqpad 5 (developer edition) v5.31.00
IQ Driver v2.1.4.0
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!