NuGet not working - FatalProtocolException

Recently, whenever I go to the LINQPad NuGet Manager, I got a "NuGet.Protocol.Core.Types.FatalProtocolException", and I cannot install new packages. The details are "Unable to load the service index for source https //api.nuget.org/v3/index.json". This URL works fine from my browser, and NuGet works fine from VS. I am not using proxies. Tried restarting my computer.
Thank you.

Comments

  • Have you reported the error via the dialog provided? And if so, what's your machine name?
  • Yes, I reported yesterday, and again now. My machine name is Eli-Desktop.
  • The log is showing an OperationCanceledException. Is it taking forever and you'll cancelling it?
  • On Monday, the manager showed 'Retrieving' for about a minute, and then it showed 'FatalProtocolException' in the LINQPad - Error dialog. Since then, the error dialog shows immediately when I open the manager.
    I never cancelled it.
  • Do you get any errors when trying to download NuGet packages using the command tool (NuGet.exe?)
  • Where is NuGet.exe?
  • I ran 'nuget install entityframework' on an empty folder, and got the following message:

    Unable to obtain lock file access on 'C:\Users\Eli\AppData\Local\Temp\NuGetScratch\lock' for operations on 'C:\Users\Eli\AppData\Roaming\NuGet\NuGet.Config'. This may mean that a different user or administator is holding this lock and that this process does not have permission to access it. If no other process is currently performing an operation on this file it may mean that an earlier NuGet process crashed and left an inaccessible lock file, in this case removing the file 'C:\Users\Eli\AppData\Local\Temp\NuGetScratch\lock' will allow NuGet to continue.
    I did what it said, and then it worked fine. However NugGet in LINQPad is still broken with 'NuGet.Protocol.Core.Types.FatalProtocolException'.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!