Query fails to start

I was very satisfied with this tool, but something strange happens by now: 4 times out of 5 (or worse) the same query, even the most primitive one fails to start. And I am getting the following message:


It happened before, but rarely. Now it becomes unusable.

Do not shadow assembly references is set to true, but not freshly. I was using it this way for years or so.

Comments

  • Have you tried re-starting your machine?

    This errors occurs when the query process starts up so slowly that the host gives up. Something is preventing the process from running normally. Is there anything unusual, such as low memory or disk space, hard drive errors? Are any other applications running very slowly?
  • There is nothing unusual. I have a mobile workstation, thus quite performant. Above 50% free CPU capacity, same on memory. Many-many GB of free space on all drives, the system is on SSD. All other applications are running normally.
  • Have you experienced the same behavior on any other computer?
  • No, as I am using it on this one only. Some additions: if I change Do not shadow assembly references to false, seems not to fail. Which makes little sense as copying should consume more time. And if I set is back to true, there is a short period when does not produce this issue. I have quite a lot of packages in my nuget cache, bot only a few (3) references added by default.
  • Are the assembly references all local?
  • Also, I take it that if you set "Run each query in its own process" to false, the problem goes away?
  • I am revoking my previous statement about "Run each query in its own process". I am still having the issue except with really simple queries. No, not all are local, I have `NewtonSoft.JSON` and `System.Reactive` by default from nuget.
  • I think I'm missing a message. If you set "Run each query in its own process" to false, does the problem goes away?
  • No. It does not. I was only experiencing this on simple queries.
  • Any idea?
  • I'm completely confused. When you set "Run each query in its own process" to false, LINQPad doesn't even try to start a new process. Have you tried re-starting?
  • Yes, of course. Seems not to have any effect on the probability of the failure. I have just restarted LinqPad, written "x".Dump(), and failed right away.
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!