Home

[Bug] Dialog boxes get stuck

I've had this happen in previous versions of linqpad.

I don't think I reported it, but it is happening a lot more recently.

It shows a dialog box (has happened on query properties, and the save/cancel. Where somehow it doesn't think the dialog is in front, so clicking things does nothing.
I can still type into the text of the current query, but can't save, or close.
ctrl-f4 to close the current query, results in yet another dialog box that won't let you click or even use the keyboard inside it.
I think it may have something to do with accidently hitting F4 and F5 at the same time.

screenshot is all I can do, since it doesn't crash or anything.

image


Comments

  • hopefully this at least gets a reply, unlike my previous bug report. =/
  • I've occasionally seen this happen (it occurs on my computer a few times a year), but have not been able to reproduce it on demand, or often enough to get the bottom of it. When I once managed to attach a debugger, it was suggestive of a bug in the Windows Forms stack, but there was nothing that suggested a workaround. If you get any further clues, let me know.
  • have you tried what I think is triggering it for me, hitting F4 and F5 almost at the same time? also, I don't seem to be getting notifications of replies in here, is there anything I can do about that?
  • oh it appears I did submit this issue before http://forum.linqpad.net/discussion/775/could-not-click-popup-window-to-submit-error#latest with no responses =( perhaps the other two were because I didn't title them as [BUG] ?
  • Yes, I've tried hitting F4 and F5 at the same time, maybe a hundred times, and have not been able to repro.
  • Sadly no further insight but just wanted to say that I also had this problem a couple times already
  • I have noticed this a few times, except that the Ctrl-F4 does not always produce another dialog box.

    At the moment, the Save Query Dialog box is displayed in front and I can't click on anything else in LinqPad (which is what you would expect with a modal dialog box), but when I press Y or N (or any other letter) it types in the query window.

    Clicks inside the dialog box are just ignored.
    Clicks outside the dialog box result in a beep and the dialog flashes several times (as per normal) but then the highlight goes off the title bar (indicating it is not the focused window). Instead the main title (currently showing LINQPad 6 Beta -Roslyn=4.0.0-3.21370.20) is still highlighted indicating that it has the focus.

    I don't think this was triggered by pressing F4 and F5 at the same time, as I was using the mouse to close the query.

Sign In or Register to comment.