LINQPAD cannot communicate to SQL2008R2 Database instances over the network

I installed LinQPad 4.0 on my machine. LinQPad Can Talk to local Database servers on my machine, but cannot communicate or add a connection to network Database servers on the network. SQL2008 Management studio on my same machine can talk to these network Servers, but SQL2012 management studio cannot. the error it reports shown in image below...I have checked the connectivity and network access to these network database servers from my machine , SQl2008 Mgmnt Studio can talk so that that should not be an issue. Turned OFF Firewall, etc. Please help

Error: A connection was established with the server, but than an error occurred during the pre-login handshake.(Provider:SSL Provider, error 0. The Operation has timed out))

Comments

  • Have you tried unchecking 'Use SSL'?
  • edited January 2013
    Yes tried unchecking SSL & SSL Invalid certs also.

    I had a similar issue trying to connect Network Database Servers via VS2012 Database Server Explorer. But then I found a Microsofot OleDb provider over Microsoft SQL Client provider in VS2012, which I selected & did that job for VS2012, but still not able to talk to DB Servers from LINQPAD & SQL2012 Management Studio.

    Installed LINQPAD on another machine which had VS2012 pre-installed, and was able to connect to the network Database servers via LINQPAD. But not sure why my dev machine cannot talk to Network DB Servers via LINQPAD. I Still Cannot connect to these Network Database servers via SQL2008R2 Management Studio though...

    Re-Installed VS2012, repaired .Net framework 4.5, etc., FW Disabled, but something could be in registry that blocks LINQPAD & SQL2012 Management Studio talking to DB Servers outside my machine boundry... need to find what is that...


  • I know this isn't much help, but I'm running LINQPad and VS2012 connecting to SQL Server 2008R2 in both applications with no difficulties. You might double-check whether the databases are using the standard ports, and like Joe mentioned try unchecking 'Use SSL'. In many cases, SSL isn't used on databases that are internal. Instead, the communication between the web server and the database occurs in the clear then the web server serves the content over SSL - at least that's how we have it setup. Obviously if the database is at a remote location SSL should be enabled. It's a tradeoff between the additional security SSL provides and the additional overhead it demands.
Sign In or Register to comment.