Unable to install pre-release packages from private NuGet server

Running version 5.36.03 (Premium edition) none of the pre-release packages on our NuGet server are being listed. This feature worked in the previous version.

using NuGet.exe I have no problem installing these pre-release packages. Also the packages are listed as expected in Visual Studio 2017, so I'm fairly confident there's nothing wrong with our internal NuGet server.

Is this a known issue? Is it possible to download a previous version of LinqPad to confirm (or not) my suspicion that it's the latest update that caused this failure?


  • I presume you've clicked the 'Include prerelease' checkbox?

    Also, try clicking 'Settings' from the NuGet package manager and enabling the legacy search engine in the Advanced tab. Does that make any difference?
  • Perfect. The "legacy Search Engine" option was what was missing. Back in business!
  • Does this setting exist within V6? I don't see it and I can't install many packages. I'm using V6.2.3 X64, netcore v3.
  • V6 doesn't include the legacy search engine.

    Can you try running the following query:

    Change the packageSourceUri to that of your NuGet server, and enter your search term. Does it return the values that you expect?
  • edited October 2019
    Yes, the query results include the alpha version I need.

    The issue remains when trying to add packages. The version is not among the results when using Add To Query/Add Specific Version To Query with the include pre-release checkbox enabled. E.G. a version value such as: '1.0.6-alpha0002'
  • So when you tick the pre-release checkbox, and type the name of your package, what happens? Does it

    (a) Show the package in the results window with the latest pre-release version
    (b) Show the package in the results window with an older pre-release version
    (c) Not show the package at all?

    And if (a) or (b), what happens when you click "Add specific version to query"? Does it:

    (d) Show nothing
    (e) Show a list of versions with some missing? And if so, is there any pattern to which versions are missing?
  • edited October 2019
    Good morning. It shows the package & description with no version info. The package detail pain displays the latest stable version only.

    After doing some tests it looks like this has to do with the interplay between our private nuget server (Proget) and version suffixes. For example, in our private Proget instance we have a nuget.org feed with several hundred packages from nuget.org.

    Linqpad will pick up alphas, pre-releases, etc. when I point it to the official nuget feed, but it will not when I point it to our private server's nuget.org feed. E.G. Microsoft.Extensions.Logging.Abstractions.

    Visual studio on the other hand picks up the pre-release versions from both our private server and the official nuget.org feed.

    It works the same way when you pick "Add specific version to query". For our private server it will only list stable versions (when the "include pre-release" box is checked).
  • Is there any update on this? Would be great to be able to install pre-release versions of packages hosted in private repos.

  • I'm seeing the same issue as described above. Pre-Release packages in a private repo do not appear in LINQPad 6. Only stable versions are displayed despite having "Include Prerelease" checked.

    The query your shared above pointed to our repo does return the pre-release version of the package in question.

  • I believe I've identified the problem. Try the latest LINQPad 6 beta:

    (If you already have an earlier LINQPad 6 beta, it will automatically update.)

    Let me know if this fixes it.

  • edited March 27

    @JoeAlbahari that totally worked. Awesome.

    Would it be possible to still have the option to install a pre-release when there is an equivalent or newer stable version? I realize this is niche, but it would be nice if the "Install specific version" popup would allow me to select from pre-release. That popup only ever shows stable builds-- unless there aren't any and then it shows pre-release.

  • This is possible if you search by ID. Type "id=…"

  • edited March 28

    I'd forgotten about that feature. Cheers.

Sign In or Register to comment.