Exception every time a try to run a query (Server process did not start)

edited July 2019
Hi! Everytime I try to run a query, Linqpad is throwing this exception, then, I need to hit cancel and try again.

Tried to reinstall, remove app data from Windows, no success...

Any help?


  • Options
    This can be caused by something blocking LINQPad.UserQuery.exe (such as group policy). Can you check the event log? Also, have you tried it on another machine?
  • Options
    Hey Joe! I cleaned the Windows event viewer, reproduced the problem and nothing gets register on event viewer. My colleague just beside me has the same issues. I Didn't try on a fresh Windows, should I ?
  • Options
    Could you also check the error log at %LocalAppData%\LINQPad\logs\log.txt?
  • Options
    5.36.03(AnyCPU) 2019-07-06T07:28:34.7317799-03:00 SymbolManager -
    COMException: Exceção de HRESULT: 0x806D0005
    em System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
    em System.Runtime.InteropServices.Marshal.ThrowExceptionForHR(Int32 errorCode)
    em System.Diagnostics.SymbolStore.SymBinder.GetReader(IntPtr importer, String filename, String searchPath)
    em LINQPad.Reflection.Internal.LocalVariableNameReader.SymUtil.GetSymbolReaderForFile(SymBinder binder, String pathModule, String searchPath)
    em LINQPad.Reflection.Internal.LocalVariableNameReader.SymUtil.GetSymbolReaderForFile(String pathModule, String searchPath)
    em LINQPad.Reflection.Internal.LocalVariableNameReader..ctor(MethodBase m)
    em LINQPad.Reflection.Disassembler..ctor(MethodBase method, ILStyler styler)
    First chance data: LINQPad.Reflection.Internal.LocalVariableNameReader+SymUtil.GetSymbolReaderForFile(binder,pathModule,searchPath) offset=0xDD
    -LINQPad.Reflection.Internal.LocalVariableNameReader+SymUtil.GetSymbolReaderForFile(pathModule,searchPath) offset=0x6
    -LINQPad.Reflection.Internal.LocalVariableNameReader..ctor(m) offset=0x48
    -LINQPad.Reflection.Disassembler..ctor(method,styler) offset=0xAF
    -LINQPad.Reflection.Disassembler.Disassemble(method,styler,offsetFrom,offsetTo) offset=0x1E
    -LINQPad.Reflection.Disassembler.Disassemble(method,offsetFrom,offsetTo) offset=0x7
    -LINQPad.Program.GetStackInfo(ex) offset=0x117
    -LINQPad.Program.GetExceptionInfo(ex,depth) offset=0x28
    -LINQPad.GuiAppHost+<>c__DisplayClass14_1.b__0() offset=0x2
  • Options
    Found the problem! Warsaw.exe (bank software to "protect" customers), uninstalled!
  • Options

    I'm facing the same issue. How did you find that particular .exe file is causing the issue?

Sign In or Register to comment.