DbContext Autocomplete isn't working anymore on v4.43.06

I might be going mad, but autocomplete doesn't seem to be working in v4.43.06
I have a premium licence and the queries are executing ok, but the autocomplete on parameters isn't working e.g.
from b in this.BusinessUnits
where b.
Initially I was using DbContext, but recently have been using LINQ to SQL, so it's possible that I've simply (gone mad) forgotten how to use DbContext properly in LinqPad.

But I'm pretty sure it previously autocompleted on pressing "." after b

I've tried using the short cut keys listed under Edit > Autocompletion to no avail.

Any ideas?


  • Options
    Autocomplete has to be working on parameters, or I'd be sent mad with complaints! I use it every second minute myself. Is there anything further that you can isolate it to?
  • Options
    Thanks for your response.

    I have recently installed VS2012 and .net 4.5 but I can't imagine it's that.

    I'll try isolate the problem.

    It's working ok in Linq to SQL, just not in DBContext v4.3 (so far that's all I've tried).
  • Options
    Argh! User error.

    I've been in the wonderful world of LinqPad + Linq to SQL, I completely forgot what I needed to do to get my EF projects to run.

    My EF projects have the DbContext in one dll and Entities in another. I cleaned up my default assembly references some time ago and completely forgot to re-add the namespace / assembly references when working with my EF projects! My bad.

    Funny how it still works, guessing my DbContext class has enough information locked in it's dll that it doesn't actually need the Entity dll's to run per-say.

    Problem solved, if anyone like me needs some more sleep.

  • Options
    edited March 2013
    I'm having the same problem. Auto complete is working on all connection types but my dbcontext. I have set up all our other developers the same way and theirs all works. I set up my second machine and a virtual and they work. There is something on this computer stopping it. When I look at the properties on a dbset collection all I see is Dump.

    I noticed that linqpad is displaying the right type in the tool tip while mousing over but F1 does not bring up the help and the Help menu does not pop up the help.

    Any ideas what could cause this?

    The answer above did not help.
  • Options
    What version are you running, Jesse?
  • Options
    edited March 2013
    Version 4.43.06
    I also tried Version:

    Its almost like the auto complete doesn't know what DBSets are or something. The compiler does because the queries run fine and I get the correct results or error messages if I fat finger something.
  • Options
    Ok I think I fixed it. I had to hit F4 and browse to the EntityFramework.dll in the bin debug folder for my dbcontext project.

    Adding EntityFramework using nuget in the F4 interface did not fix it. Only that specific dll did. Questing is why did I not have to do that on all my computers? Also what EntityFramework reference does Linqpad use by default?
Sign In or Register to comment.