Home

RichText- Result pane is emptied when clicking on a collection box header

Starting today I run into a desperate situation: When clicking onto the header of Dump box containing a collection (e. g. IEnumerable<>) in the Result Panel to collapse or expand it, the background in the result panel gets white as well as the foreground, thus emptying the HTML result pane. Only pressing F5 recalculates and redraws the results.

I suspect that this malfunction has something to do with the internet explorer colors, because I was tinkering with inetcpl.cpl recently.

Unfortunately I'm not able to repair this problem, I tried everything, reinstalling LinqPad with prior deletion of all config files in %programdata%, %appdata% and %localappdata%. Copying IE settings from a local windows account on the same machine, that does not experience this problem. But all to no avail.

This problem happens in LinqPad5 and 6, with dark and with light theme and default result formatting.
Since I use LinqPad very heavily for my developing job, I am now in a deplorable situation.
Does anyone have an advice how to resolve this? (I want to refrain from reinstalling the OS.)

Comments

  • To demonstrate what I mean, I provide two screenhots, the second one after clicking on IEnumerableOfInt32.

  • Can you do a "View source" in the result panel after collapsing/expanding the table header?

    It looks like the result of Context menu > Refresh in results pane. Something is refreshing the browser window after a javascript action. Do you have any custom add-ins enabled in Internet Explorer?

    Is the value Use_DlgBox_Colors set to 'no' in HKCU\Software\Microsoft\Internet Explorer\Main ?

  • edited July 24

    Hi nescafe,

    your hints pointed me to the right direction.

    The source of the empty Result pane was simply

    <HTML></HTML>
    

    , but the source of the original Result pane looked fine. I saved this html code into a file and tried to execute it in IE.
    This yielded the warning Internet Explorer restricted this webpage from running scripts or ActiveX controls. and clicking on the Allow blocked content button executed the HTML source correctly. After googling this warning message, I found the culprit with aid of this blog: In the Internet options dialog, Advanced tab, section Security, selecting checkbox Allow active content to run in files on My Computer* solved the problem.

    Interestingly, on another machine where LinqPad's Result pane behaves as expected, this checkbox is disabled. So there may be more IE security settings that interact in a way not clear to me.

    Many thanks, Franz

Sign In or Register to comment.