Home

System.TimeoutException

Hi. Since yesterday I've been getting a System.TimeoutException on most queries that I run. It works sometimes without me having to do anything, but it's getting the error easily over 90% of the time. I'm running version 6.10.13.

This only started yesterday. I've been using Linqpad for years without ever seeing this, and nothing has changed on my machine. Since I'm working from home, and have been since March, I'm using a VPN to connect to our domain. It's been working reliably all that time until yesterday. Oddly enough, I have a virtual machine connected directly to our domain that I can RDP into (effectively bypassing the VPN) and it works 100% of the time there.

Is there anything you can think of that could help me out? I'm sure it's probably a VPN issue on our end, possibly a some sort of contention issue, but in the meantime is there any settings within Linqpad that can possibly change the timeout?

Oh, I should point out that the error comes up pretty quickly. Usually less that 5 seconds, no matter how complex or simple the query might be.

Aside from this issue this week, I genuinely love Linqpad. It's a great product and I'm delighted I got the full license for it. It's made my work so much simpler

Comments

  • I should just add that from my local machine (the one with the problem) I can query the same databases from SQL Management Studio without any problems

  • I'm also seeing a similar problem. LINQPad takes an age to start up and once it does I'm unable to run any query. After about 3 seconds the timeout exception occurs. I've tested with the latest release version v6.10.13 and the latest beta version v6.11.8. Both x64 and x86 version behave the same. Changing the language or .NET runtime also seems to have no effect on behaviour. Whatever the cause is LINQPad is now totally unusable for me, which is something of a nuisance as I use it regularly.

    I only started noticing this yesterday. The only thing that I can think of that has changed over the past few days is that I cloned the ASP.NET Core repo and installed the items required to build the repo, as well as the latest preview version of VS 2019. However, that may just be a coincidence.

  • Can you tell me the names of your machines, so I can match the error report?

  • Can you tell me the names of your machines, so I can match the error report?

  • LPT4491

    I think I submitted an error report yesterday. However, I can easily submit another if necessary.

  • Please run the latest beta:
    https://www.linqpad.net/linqpad6.aspx#beta

    Instead of a TimeoutException, you should now receive a ProcessInitializationException. Please submit the error report - it will include a stack trace of all the threads on the target process, which should help me locate the source of the timeout.

  • Error report just submitted.

  • Thanks - I've got it. Could I trouble you to submit the error report once or twice again, so I can verify whether it always times out in the same spot.

  • edited November 9

    Also, can I ask how long LINQPad takes to start on your machine - from the type you click the icon to the time that you can start typing?

    And does anything else run slowly on your machine? If so, is there any possible cause, such as lots of files in your %temp% folder?

  • I've just submitted three additional error reports. Here are the approximate times taken to start from three runs:

    72 seconds
    115 seconds
    72 seconds

    (The machine I'm running from has a half-decent spec, e.g. Core i7-8850H, 32 GB RAM, SSD etc.)

  • Thanks for the info. LINQPad shouldn't take longer than ~6 seconds to start up on your hardware. The slow startup time is almost certainly related to the timeout errors when running a query. It looks like the CLR is taking forever to load assemblies - it gets stuck in the following function in AssemblyLoadContext:

    private static extern IntPtr LoadFromStream(IntPtr ptrNativeAssemblyLoadContext, IntPtr ptrAssemblyArray, int iAssemblyArrayLen, IntPtr ptrSymbols, int iSymbolArrayLen, ObjectHandleOnStack retAssembly);

    Because I regularly receive timeout error reports, I'm going to wait for others to come in and see whether they stick in the same spot - then I will know whether your problem is typical or special.

    @dannytheking - if you could also run the beta and submit an error report, that would be great.

  • edited November 10

    P.S. Are you using third-party antivirus software? If so, can you please check the logs, and try disabling it?

  • edited November 13

    Interestingly, I've just updated VS 2019 to v16.8.1 and that appears to have fixed the problem. (I was running v16.7.7 previously.)

    On the AV question: yes, McAfee Endpoint Security is running and it does seem to be incorrectly identifying LINQPad as possible malware. The logs confirm that it is not blocking LINQPad though. As it's a corporate machine it's unlikely I'll be able to disable the AV. However, that's obviously moot now as it looks like the AV wasn't the cause of the problem.

  • Hi, sorry for the delay in getting back to you. The latest version which I grabbed last week seems to have solved it. Interestingly, too, version 5 was never affected so I was at least able to work away with that. It's all good now, though. But if it happens again I'll submit the error report and give you the machine name.

Sign In or Register to comment.