LinqPad5 all queries are unlachable since today on 2 machines


since today, all queries have become manually unlanchable on 2 virtual servers

Thank god, automatic runs via lprun.exe are still working.

Screen and log below, can anybody help?

Restart did not help. I have strong suspition that recet Chrome update changed some windows files...

5.43.00(AnyCPU) 2020-11-18T11:53:05.8212345+01:00 SymbolManager -
COMException: Exception from HRESULT: 0x806D0005
at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
at System.Runtime.InteropServices.Marshal.ThrowExceptionForHR(Int32 errorCode)
at System.Diagnostics.SymbolStore.SymBinder.GetReader(IntPtr importer, String filename, String searchPath)
at LINQPad.Reflection.Internal.LocalVariableNameReader.SymUtil.GetSymbolReaderForFile(SymBinder binder, String pathModule, String searchPath)
at LINQPad.Reflection.Internal.LocalVariableNameReader.SymUtil.GetSymbolReaderForFile(String pathModule, String searchPath)
at LINQPad.Reflection.Internal.LocalVariableNameReader..ctor(MethodBase m)
at LINQPad.Reflection.Disassembler..ctor(MethodBase method, ILStyler styler)
First chance data: System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(errorCode,errorInfo) offset=0xFFFFFFFF
-System.Runtime.InteropServices.Marshal.ThrowExceptionForHR(errorCode) offset=0xF
-System.Diagnostics.SymbolStore.SymBinder.GetReader(importer,filename,searchPath) offset=0x92
-LINQPad.Reflection.Internal.LocalVariableNameReader+SymUtil.GetSymbolReaderForFile(binder,pathModule,searchPath) offset=0xDD
-LINQPad.Reflection.Internal.LocalVariableNameReader+SymUtil.GetSymbolReaderForFile(pathModule,searchPath) offset=0x6
-LINQPad.Reflection.Internal.LocalVariableNameReader..ctor(m) offset=0x48
-LINQPad.Reflection.Disassembler..ctor(method,styler) offset=0xAF
-LINQPad.Reflection.Disassembler.Disassemble(method,styler,offsetFrom,offsetTo) offset=0x1E
-LINQPad.Reflection.Disassembler.Disassemble(method,offsetFrom,offsetTo) offset=0x7
-LINQPad.Program.GetStackInfo(ex) offset=0x117
-LINQPad.Program.GetExceptionInfo(ex,depth) offset=0x28
-LINQPad.GuiAppHost.FaultInternal(ex) offset=0x7
-LINQPad.GuiAppHost.Fault(ex) offset=0x3D
-LINQPad.Program.ProcessException(ex) offset=0xC
-LINQPad.ThreadingExtensions+<>c__DisplayClass0_0.b__0(ant) offset=0x15

Thank you,



  • What antivirus software are you using? Is there anything in the antivirus logs?

  • @JoeAlbahari said:
    What antivirus software are you using? Is there anything in the antivirus logs?

    I found 3rd machine in same network with same problem. Not sure, if same antivirus sw is on machines mentioned by Hubert, but in this case BitDEfender Endpoint Security Tools are in use. I didn't found any info from log, I saw only 0 files in quarantine, no more useful info is present.

    Just to "try something"I tried beta 5.44.00 with same result.

    Kind regards Jindrich

  • Can you try running LINQPad 6 to see whether the result is any different?

    Also, has there been any recent group policy change?

    And does it work if you set the "Run each query in its own process" option to false in Edit | Preferences > Advanced?

  • LinqPad6 is working, I just tried it. But I'm not sure if this is acceptable solution for Hubert (whois on vacation, so I cannot confirm it wtih him)

    I don't have any info about GP change and I realy didn't expect, that there will be any change.

    Kind regards Jindrich

Sign In or Register to comment.