LinqPad 7 Terminating on Production Servers

I have performed an XCopy deploy of LinqPad 7 (7.3.9) on a disconnected production Server (2019 standard).
If I start LinqPad (LINQPad7-x64.exe) - then do nothing - it will terminate after a bit more than two minutes. There is nothing recorded in the LinqPad logs. The only logging I can find anywhere is in the Windows Security log - where there is a process termination entry for linqpad...

A process has exited.

Security ID:
Account Name:
Account Domain:
Logon ID: 0x3A499B03

Process Information:
Process ID: 0x5a8
Process Name: \linqpad\LINQPad7-x64.exe
Exit Status: 0x1

..immediately after this Security log entry there is another three Process Termination logs for...

  • LINQPad.DriverProxy.LINQPad.Drivers.EFCore.exe
  • LINQPad7.Query.exe
  • LINQPad.DriverProxy.LINQPad.Drivers.EFCore.exe
    ...for these subsequent log entries, all of the executables are running from the %appdata%/local folder, and the exit status is 0x0.
  1. I have tried redeploying several times from different sources to discount corruption of the LinqPad files
  2. I have deployed to a different production server (which is successfully running LinqPad 5) - and see identical issues
  3. I have tried temporarily disabling the local Windows firewall
  4. I have added LinqPad7-x64.exe (and the other 'sub' exe's) to be excluded from Exploit Protection.
  5. I have deployed to a non production server (which is also disconnected - but running Server 2012 R2 Standard) - with no problem!

I have trawled through the forum for similar issues - this is the only one that seems to be similar to mine...
...but the recommended solution did not help me.

Is there anything else I can try to identify what is causing LinqPad 7 to terminate on my production servers?


Sign In or Register to comment.