LINQPad5.exe not found error

When running a simple select, "from a in AddressTypes select a", against my own EF model I'm receiving the following error: "ArgumentException: Requested value 'C:/Program Files (x86)/LINQPad5/LINQPad.exe' was not found."

Running AddressTypes.Count() or creating an anonymous type works fine. Even running "var abc = from a in AddressTypes select a;" works but "abc.Dump();" throws the can't find LINQPad.exe error.

I'm running LINQPad 5 v5.46.00.

I'm assuming this is a setup issue on my end but I can't figure out what. Can anybody help me get this corrected?


  • Options

    Not sure why I didn't try this before however, I finally tried querying other entities and the entities based on tables in the dbo schema work fine. Entities based on tables in other schemas throw the error about not finding LINQPad.exe.

    Running SQL Profiler while executing the LINQPad query I see valid SQL generated and that SQL has the correct schema listed and does return the correct results.

    Is there some configuration that I need to do to have LINQPad work correctly when multiple schemas are involved in a custom entity model?

  • Options

    Solved. It was an internal issue with how we are instantiating the DBContext.

Sign In or Register to comment.