LinqPad7 won't start after VS2022 Update/.Net 8.0 installed

I updated VS2022 to 17.8 last week to get .Net 8 installed, and now LINQPad7 won't launch. I get a "Download .Net" dialog that appears to be looking for (and finding!) .Net 7.0.14, but I guess that's just not good enough. I just updated VS to 17.8.1 and no change:

The Launch LINQPad (x64) and Launch LINQPad (x86) buttons at the bottom are active, but when I click on either one, I just get a new instance of the dialog.

Please advise.


  • You're running an old version of LINQPad 7 - have you been blocking automatic updates? Please download the latest RTM (7.7.15) and report back.

  • Updates are controlled by IT at my company so I don't have control over updates. This morning their admin software pushed 7.7.15 out to my machine, but I still have the same issue:

  • I am having the same problem on both my x64 and ARM64 machines.

  • Can you both please report what's in your startup log file at %localappdata%\LINQPad\logs.LINQPad7\startup.txt

  • I have this block of text repeated over (with different timestamps of course):

    2023-11-28 13:01:21 PromptForFxInstall: Directory 'C:\Program Files\dotnet\host\fxr' does contain any valid .NET folders. Target DLL: C:\Program Files\LINQPad7\LINQPad.GUI.dll dotnet root detected via registry: C:\Program Files\dotnet\ Probing C:\Program Files\dotnet\host\fxr Probing C:\Program Files\dotnet\shared\Microsoft.NETCore.app Probing C:\Program Files\dotnet\shared\Microsoft.WindowsDesktop.App Using dotnet root: C:\Program Files\dotnet\ AllowPrerelease=true Searching C:\Program Files\dotnet\host\fxr...

  • edited November 2023

    All I have is an 8.0.0 folder under the C:\Program Files\dotnet\host\fxr folder, though my VS2022 install includes .NET 7.0 Runtime. hostfxr.dll exists under C:\Program Files\dotnet\host\fxr\8.0.0

    Looks like VS 17.8.2 has released, I'll update and see if that changes anything.

    No change after updating to 17.8.2.

    dotnet --info reports the following SDKs/Runtimes installed:

    `.NET SDKs installed:
    8.0.100 [C:\Program Files\dotnet\sdk]

    .NET runtimes installed:
    Microsoft.AspNetCore.App 6.0.25 [C:\Program Files\dotnet\shared\Microsoft.AspNetCore.App]
    Microsoft.AspNetCore.App 7.0.14 [C:\Program Files\dotnet\shared\Microsoft.AspNetCore.App]
    Microsoft.AspNetCore.App 8.0.0 [C:\Program Files\dotnet\shared\Microsoft.AspNetCore.App]
    Microsoft.NETCore.App 6.0.25 [C:\Program Files\dotnet\shared\Microsoft.NETCore.App]
    Microsoft.NETCore.App 7.0.14 [C:\Program Files\dotnet\shared\Microsoft.NETCore.App]
    Microsoft.NETCore.App 8.0.0 [C:\Program Files\dotnet\shared\Microsoft.NETCore.App]
    Microsoft.WindowsDesktop.App 3.1.32 [C:\Program Files\dotnet\shared\Microsoft.WindowsDesktop.App]
    Microsoft.WindowsDesktop.App 6.0.25 [C:\Program Files\dotnet\shared\Microsoft.WindowsDesktop.App]
    Microsoft.WindowsDesktop.App 7.0.14 [C:\Program Files\dotnet\shared\Microsoft.WindowsDesktop.App]
    Microsoft.WindowsDesktop.App 8.0.0 [C:\Program Files\dotnet\shared\Microsoft.WindowsDesktop.App]`

  • That is strange. Under the fxr folder, create a copy of the 8.0.0 folder and rename it 7.0.14. (The 8.0.0 hostfxr should work for 7 as well.)

  • That worked for me, thank you very much!

  • I just wanted to add that I had the exact same issue here and probably the same circumstances (upgrading Visual Studio, installing .net 8 etc). The workaround for creating the 7.0.14 folder worked for me too.

Sign In or Register to comment.