Migrating to new machine - Linqpad unable to save to plugins folder?

I've been using Linqpad on my work machine to help with various tasks and have recently moved all my previous work onto a different machine. Copied all settings and scripts to the respective places on the new machine and everything so far has been fine.

Needed to run a script that utilized my extensions and remember that I need to "recompile" it. Opening up the file I see the default extensions file and not mine. I double checked the file and it seemed fine, all my code is there. So I figured I'll just copy the code and imports to it and resave. Apparently it's not able to access the plugins folder to save?

It's not a permissions issue, I'm able to access other queries fine. It's in a One Drive synced location but that wasn't an issue on the other machine. It was also in a One Drive synced location and I also migrated previously with that one, followed the same procedure I'm doing now.

Is there something else I can check to try to diagnose this issue?

The only change I make WRT LINQPad folders is put all the related folders into a common base LINQPad folder and this is usually not a problem.


  • Options

    Hmm, had to delete the Plugins folder and let LINQPad create it instead. It wasn't enough to delete the NetCore3 folder. Then tried to save again and now it worked. Not sure why it wouldn't let me save but there you go.

Sign In or Register to comment.