Home

LINQPad with Azure - Format Exception - String was not recognized as a valid Boolean

I'm connecting to an Azure table with LINQPad but for some reason the connection fails with the error:

Error: FormatException - String was not recognized as a valid Boolean.

Based on another discussion in this forum regarding DateTimes, I scoured the tables to try and find if I had any columns with invalid Boolean data, but I can't seem to find any Boolean columns at all, so I've got no good idea where this error is coming from. I can still connect to the table using Azure Storage Explorer, so I can search for problems there.

Any ideas on what the problem might be?

Comments

  • Are you using Azure Table Storage or SQL Azure?
  • Well, I finally had some time to sit down and figure out what was going. Debugging with VS gave me a stack trace that lead me to the actual source of the error (which was a format exception in the AzureStorageDriver) while attempting to read the UseHttps property from the XML configuration.

    Dug around a bit more to find out where exactly this file is located and found it in the Roaming AppData folder.

    It turns out that that element was missing (because it was defaulted to false), and I'm assuming that when the app attempted to parse string.Empty as a bool, it failed. Adding false to the xml document and re-loading LinqPad fixed the problem.

    Hope anyone else running into this problem is able to figure it out the same way.
Sign In or Register to comment.