LINQPad renders html source rather than well, html

edited June 2012
I had been running version for a while and thought I'd just check for updates (since auto update feature does not work for me)

The latest versions for either 4 or 3.5 framework have the same problem and gives me the html source when I execute a simple c# statement. Good thing LINQPad is stand-alone exe. When I run the old version, it renders html correctly.

BTW, as I stated above, auto update does not work for me, even after configuring the proxy. And I don't know what the real problem is because I don't know if LINQPad logs and where it logs if it does. The error message given is:
Error: An exception occurred during a WebClient request.


  • LINQPad uses the .NET WebBrowser control to display the HTML. If it's not rendering, perhaps something's awry with the .NET Framework installation or the operating system.

    If you have a proxy, LINQPad should be able to detect updates if the details are entered correctly. What kind of proxy server is it?

    The logs folder is %localappdata%\linqpad\logs
  • edited July 2012
    First, regarding the proxy, I found that I had to put in the address as http://proxyserver. I started up fiddler and pointed LINQPad to it but I saw no traffic at all. I then for some reason thought to prepend the address with the scheme and it worked. I was scratching my head since normally I don't have to do that.

    The log file doesn't contain much and the content is from 2 years ago anyway.

    As for the WebBrowser control, as I stated in the original post, version works just fine. I'd think that the new version 2.42.01 - I did download the 3.5 version - and the old, both, run on the same version of .net framework, namely 2.0/3.5. Is that not the case?

    I am running both on Windows XP SP3 with IE6 - corporate standard.

    Thanks for a great product!
    I don't use it much for linq but it's an awesome snippet compiler!
  • My computer at work died and I'm building a new one but I can't find the old LinqPad version ( As I stated in this thread, the latest versions don't render HTML correctly. I was mildly surprised that they still don't work on this new machine (same OS, etc. though).

    Since I don't see the links on the website, is there a way to get my hands on the previous versions of LinqPad?
  • Nothing's changed in the way LINQPad renders HTML. Could something in your group policy be allowing only that specific version of LINQPad to access Internet Explorer? I've just tested the latest LINQPad executable with XP SP3 and IE6, and it works as expected.

    I've uploaded the old version to http://download.linqpad.net/135/LINQPad.exe if you want to keep running that version.

  • I don't know of any group policy that would specifically target this version.
    If you can upload a later version perhaps something before v2 but after 1.3.5, I can test out your scenario regarding group policy.

    Other than that, if you have the debug build of the latest version, I can run that and give you whatever the output that you need to troubleshoot this further.

    BTW, I had a bit of fun chasing down the location of downloaded update using procmon. I chased it down to C:\Documents and Settings\All Users\Application Data\LINQPad and deleted the downloaded update. Then I removed my proxy settings to prevent further updates from downloading. Otherwise, 1.3.5 would automatically be overwritten by the latest downloaded version.
  • Or if you put up different versions, I could download them all, test out one by one, and narrow down where the possible change happened that causes this issue.
  • Sorry, I should have said that you can tell LINQPad not to check for updates and not to forward to newer versions by starting it with the -noupdate and -noforward switches.
  • that's good to know, thanks for the tip!
Sign In or Register to comment.